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Chapter 3:
Animation

After completing this module, you’ll be able to:

•	 create,	comment,	and	use	frames	and	keyframes.
•	 distinguish	types	of	Flash	animation.
•	 create	motion	tween	animation.
•	 control	animation	with	motion	guide.
•	 control	animation	with	easing.
•	 create	shape	tween	animation.
•	 save	and	share	your	animation.

If	you	just	wanted	to	create	graphics	and	text,	many	software	packages	
would	work.	What	makes	Flash	exciting	is	animation!	Animation	involves	
change	over	time.	The	Timeline	is	used	to	manage	your	graphic	elements.	

Creating Frames and Keyframes
The	Timeline	is	the	key	to	animation.	As	you	look	at	the	Timeline	you’ll	

notice	the	numbers	across	the	top	and	the	layers	along	the	left	side.	Each	
number	has	a	matching	frame.	These	frames	are	white	when	they	are	emp-
ty	and	turn	gray	when	they	contain	content.	

To	create	animation,	you’ll	be	manipulating	two	types	of	frames:	key-
frames	and	regular	frames.	

A keyframe	is	a	point	in	your	movie	where	new	content	first	appears.	
They	are	the	key	to	animation.	In	keyframes	you	can	also	scale	and	reposi-
tion	elements.	The	first	frame	of	each	layer	is	a	
keyframe.	You	can	always	identify	the	key-
frames	because	they	contain	a	tiny	filled	circle.	

Regular frames are static and contain 
the	same	content	as	the	preceding	keyframe.	
They’re	sometimes	called	“slaves”	to	the	key-
frame.	Frames	contain	a	hollow	circle.
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Right	now	our	movie	only	contains	one	frame,	a	keyframe.	You’ll	want	
to	estimate	how	many	frames	you	think	you’ll	need	in	your	movie.	We’re	
going	to	create	an	animation	that’s	about	10	seconds	in	length.	Most	devel-
opers use a frame rate	of	12	frames	per	second	(fps)	which	is	the	default	in	
Flash.	For	a	movie	10	seconds	in	length	at	12	fps,	we’ll	need	120	frames.	We	
can	always	add	or	remove	frames	if	we	decide	to	change	the	length	of	our	
movie.

To insert frames on the Timeline:
Click on frame 120 of the welcome layer.
 Look for the grey band at to 

find frame 120; click on it.
Shift-click on each of the other 

layers down to the cloud 
layer.

 As you shift-click on each 
layer it will turn gray.

Pull down the Insert menu, choose Timeline, and select Frame.
 The frames will all be shaded with gray because each layer con-

tains content. The last frame (120) will contain a white rectangle.

Creating Keyframes
Right	now,	all	the	elements	appear	on	the	first	frame	and	nothing	hap-

pens	for	the	entire	length	of	the	movie	(120	frames).	Not	every	exciting,	
huh?	We’ll	add	keyframes	at	points	in	the	movie	where	we	want	the	con-
tent	to	change.	For	example,	we	want	the	runway	to	disappear	after	the	
plane	has	taken	off	and	we	don’t	want	the	grass	or	house	to	show	until	
the	plane	has	reached	the	end	of	the	runway.	We	might	want	the	cloud	to	
appear,	disappear,	and	reappear	in	a	different	position	giving	the	feeling	
that	the	airplane	is	moving	across	the	sky.	At	this	point,	we	can	only	guess	
where	we	want	these	changes	to	take	place.	Keyframes	are	easy	to	adjust	if	
we	decide	we	want	to	change	the	timing	of	different	elements.

Let’s	start	with	the	Welcome	layer	containing	our	text	Rather	than	show-
ing	the	question	“Have	you	ever	wondered	how	airplanes	fly?”	at	the	
beginning	of	the	movie,	let’s	just	show	it	during	the	last	20	seconds	of	our	
movie.	We’ll	make	a	new	keyframe	at	Frame	100.	Then,	delete	the	content	
from	Frame	1.

keyframeframe
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To add a keyframe:
Click Frame 100 of the Welcome layer.
 Sometimes, it’s difficult to tell which frame you’re selecting. The 

status bar at the bottom of the Timeline shows the selected 
frame.

Pull down the Insert menu, choose Timeline, select Keyframe.
 You can also use the F6 key to insert a keyframe.
 A solid black circle will appear in Frame 100. Notice that there’s 

now a line between Frames 99 and 100. A rectangle appears in 
Frame 23 indicating the end of the frame segment. 

Click on Frame 1 of the Welcome layer.
Press the Delete key.
 Notice that Frame 1 of the Welcome layer now has a white circle 

rather than a black circle. Also notice that the frames between 1 
and 99 are now white which means they are empty.

Commenting Frames
Since	our	movie	is	only	10	seconds	long,	it’s	not	difficult	to	remember	

what	happens	in	the	project.	However	if	your	movie	were	10	minutes,	there	
could	be	hundreds	of	keyframes.	Frame comments allow	developers	to	
record	text	descriptions	for	keyframes.	This	helps	you	remember	the	events	
that	take	place	at	important	points	in	your	animation.	These	comments	
won’t	be	exported	or	viewed	by	end	users,	so	they	don’t	need	to	be	pretty,	
just	descriptive.

To add a comment to a frame:
Select Frame 100 of the Welcome layer.
 You should select the frame where you wish the comment to be 

recorded.
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In the Properties panel, click in the area 
under the word Frame.

Type: //question appears
 All comments should start with 2 

slashes. This indicates that they are 
comments, not frame labels.

 Notice that your frame comment now 
appears in the Timeline.

Creating Animation
Flash	contains	cool	features	for	creating	a	variety	of	animations.	Flash	

offers	four	ways	to	create	animation.

Frame-by-Frame.	The	most	flexible	approach	is	called	frame-by-frame	
animation.	With	this	type,	the	developer	makes	small,	individual	changes	
to	objects	on	the	Stage	within	every	frame.	Although	effective,	this	can	be	
very	time-consuming.	If	you’ve	tried	making	a	flip-book	or	creating	clay-
mation,	you’re	familiar	with	this	approach.	Since	Flash	is	a	frame-based	
program,	it’s	easy	to	move	from	frame-to-frame	to	make	these	changes.	
With	frame-by-frame	animation,	you	can	make	incremental	changes	in	the	
placement	of	the	object	to	give	the	appearance	of	motion	(i.e.,	swinging	
pendulum,	playing	on	seesaw,	or	raft	floating	on	water).	In	addition,	you	
can	change	the	object	itself,	so	it	looks	like	it	had	been	transformed	(i.e.,	
pumpkin	turns	into	a	jack-o-lantern,	a	frown	turns	into	a	smile,	a	plant	
grows).	

Tweening	is	a	technique	used	to	make	animation	much	easier.	The	de-
veloper	identifies	a	start	point	and	end	point,	then	the	software	figures	out	
the	positions	of	the	objects	“between.”	Flash	contains	two	types	of	tweens:	
motion	tweens	and	shape	tween.

Motion Tweening.	Motion	tweens	move	objects	from	one	place	on	the	
Stage	to	another.	For	example,	we’ll	move	the	airplane	across	the	Stage.	The	
developer	places	an	object	at	the	starting	point	at	a	Keyframe.	Then,	cre-
ates	a	Keyframe	somewhere	along	the	Timeline	and	moves	an	instance	of	
the	object	to	the	end	point.	The	creator	returns	to	the	beginning	frame	and	
chooses	the	motion	tween	option.	The	software	then	moves	the	object	on	a	
direct	path	from	the	beginning	to	the	ending	point.	Flash	provides	options	
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to	tweak	the	tweening	so	that	it	looks	more	realistic.	For	example,	motion	
guide	can	be	used	to	move	the	animation	along	an	established	line	so	it	
looks	like	a	plane	is	taking	off.	Easing	is	used	to	make	it	look	like	a	ball	is	
really	bouncing.

Shape Tweening.	Shape	tweens	morph	one	image	into	another	image.	
For	example,	we’ll	change	the	shape	of	the	cloud	as	is	moves	across	the	
Stage.	You	could	also	change	circles	into	stars,	a	seed	into	a	plant,	or	a	bike	
into	a	car.	Keep	in	mind	that	shape	tweening	only	really	works	well	with	
the	vector	graphics.	In	other	words,	Flash	shape	tweening	won’t	work	well	
on	a	photograph	of	a	human	face,	but	it	would	work	for	a	line-based	smiley	
face.	

ActionScript.	Besides	frame-by-frame	and	tweening,	objects	can	be	ani-
mated	using	ActionScript.	In	addition	to	animation,	scripting	is	also	used	
for	highly	interactive	projects	such	as	video	games	and	simulations.	Finally,	
you	can	also	choose	from	pre-built	animations	provided	by	Flash.

Creating Frame-by-Frame Animation
Let’s	have	some	fun	with	frame-by-frame	animation.	For	this	assign-

ment,	let’s	create	a	web	page	banner	rather	than	a	standard	screen	size	
document.

We’ll	begin	by	creating	a	new	document	and	setting	the	page	properties.

To set the page properties:
Create a new document. 
In the PROPERTIES area of the Properties panel, choose to Edit... 

next to the Size option. 
Change the size to 550 x 100 pixels. 

Notice that you can change the Background Color and Frame 
rate here.
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Next,	we’ll	create	a	picture	for	the	simple	animation.	Use	the	line	and	
shape	tools	to	draw	a	simple	stick	person	on	the	extreme	left	side	of	the	
screen.	You	could	also	draw	a	globe,	basketball,	car,	or	other	object.	For	a	
circle,	click	the	Rectangle	tool	and	draw	a	circle.	Use	the	line	tool	to	create	
lines.

Building	the	animation	involves	creating	a	series	of	keyframes	with	
small	changes	to	the	figure.	The	default	setting	is	12	frames	per	second.	
Let’s	create	movement	every	5-10	frames.

To create frame-by-frame animation:
 Click on Frame 5. Pull down the Insert menu, choose Timeline 

and Keyframe. Note the dot.
Click on Frame 15. Add another Keyframe. Also add Keyframes on 

20, 25, 30, and 40.
Click on Frame 1. Pull down the Edit menu, Select All. Pull down the 

Edit menu, choose Copy.
Go to Frame 5. Pull down the Edit menu, choose Paste. Go to all the 

other frames and paste. 
Go back and make small changes on each Keyframe such as mov-

ing legs or arms. You can also go to the Modify menu and choose 
Transform to make changes such as rotation.

To test your animation:
Pull down the Control menu and choose Test Movie.
To use your controller, pull down the Window menu and choose 

Toolbars and Controller. The Controller provides more flexibility in 
viewing your project.

Pull down the File menu, choose Export, and Export Movie.

By	saving	the	movie	as	an	.SWF	file	you	can	share	your	project	with	oth-
ers	and	even	insert	it	into	a	web	page.
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Creating Motion Tween Animation
The	most	common	animation	technique	is	motion	tweening.	You	simply	

provide	Flash	with	a	starting	point	on	a	keyframe	and	an	ending	point	on	
another	keyframe.	Then,	you	set	the	motion	“tween”	and	watch	it	anima-
tion!	

The	motion	tween	animation	options	have	changed	dramatically	from	
earlier	versions	of	Adobe	Flash.	If	you	have	an	older	version,	you’ll	need	to	
adjust	the	instructions.	The	newest	version	contains	both	the	“classic	mo-
tion	tween”	as	well	as	a	new	approach.	We’ll	try	both	in	this	section.

Classic Motion Tween
Keep	in	mind	that	you	can	only	use	graphic	symbols	and	movie	clips	as	

motion	tweens.	We’ll	create	a	motion	tween	to	move	our	airplane	across	the	
Stage.

To create a “classic” motion tween for our airplane:
Unlock the airplane layer if you locked it earlier. 
Ensure that your object is a SYMBOL before you create your anima-

tion. If you’re not sure, pull down the ModifToolbars, y menu and 
select Convert to Symbol. Give it a name and make it a graphic.

Select Frame 120 of the airplane layer.
Pull down the Insert menu, choose Timeline, select Keyframe.
 Notice that the airplane copied to your new Keyframe.
Drag the airplane so it appears in the upper right corner of the Stage.

Figure 3-A. Classic Motion Tween.
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Click Frame 1 of the airplane layer.
 Tweens span the distance between the two keyframes. However, 

the tween is associated with the starting keyframe.
Pull down the Insert menu, choose Classic Motion Tween.

You’ll see that the airplane layer now has turned blue and con-
tains an arrow.

Preview the tween on the Timeline by dragging the Playhead where 
the Timeline numbers appear. This is called scrubbing the Time-
line. The Playhead is the number band across the top of the 
Timeline.

Or, pull down the Control menu, choose Test Movie.
Or, pull down the Window menu, choose Toolbar and Controller.

When	you’re	working	with	a	Classic	Motion	Tween,	use	the	Property	
menu	to	add	easing	and	other	features	such	as	rotation	of	your	plane	clock-
wise	(CW)	or	counter-clockwise	(CCW).

Motion Tween 
The	second	option	for	tween	animation	is	the	new	Motion	Tween	op-

tion.	The	advantage	of	this	approach	is	that	you	don’t	need	to	mess	with	
creating	keyframes,	the	system	creates	a	guide	automatically.

To create a motion tween for our airplane:
Unlock the airplane layer if you locked it earlier. 

Figure 3-B. New Motion Tween.
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Ensure that your object is a SYMBOL before you create your anima-
tion. If you’re not sure, pull down the ModifToolbars, y menu and 
select Convert to Symbol. Give it a name and make it a graphic.

Click on Frame 1 of the airplane layer.
Pull down the Insert menu, select Motion Tween.

The Timeline will turn blue from Frame 1 to 120.
Click on the Frame where you’d like to see your first movement, this 

case Frame 10. 
Drag the airplane to the new location an inch above the runway.

A special Keyframe called a Property Keyframe will be added to 
the Timeline after you’ve changed the position of the graphic. It 
looks like a filled triangle.

Click on Frame 20. Drag the airplane back down to the runway.
Make movements for Frames 40, 80, 100, and 120 to simulate the 

way an airplane bounces down the runway.
Remember that you can start and end an animation off the stage 
if you wish.

If you wish to adjust the guide, click on the Property Keyframe con-
taining one of the keyframes made by the tween and move the 
graphic. The guide line will automatically be adjusted.

The	new	Motion	Editor	provides	additional	tools	for	enhancing	your	
Motion	Tween.	Click	the	MOTION	EDITOR	tab	next	to	the	TIMELINE	tab.	
This	allows	you	to	change	No	Ease	to	Simple	(Slow).	You	also	have	more	
precise	movement	of	your	Property	Keyframes.

Creating Shape Tween Animation
It’s	fun	to	morph	images.	Tweening	shapes	involves	changing	an	ob-

ject’s	shape	at	one	or	more	points	in	the	animation.	The	software	creates	the	
in-between	shapes	for	you.	You	can	combine	changes	in	position	as	well	as	
changes	in	size,	color,	and	transparency.	You’ll	want	to	work	with	just	one	
shape	per	layer.

Unlike	motion	tweening	that	uses	graphic	symbols,	you	can’t	shape	
tween	on	a	symbol,	text,	or	a	group	unless	you	break	them	apart.	Shape	
tweening	works	best	on	objects	that	you	create	using	the	draw	tools	such	
as	our	cloud.	Let’s	try	a	couple	shape	tweens.	First,	we’ll	create	a	simple	
alphabet	book.	We’ll	start	with	an	apple	that	changes	into	the	letter	A.

To create the shape tween:
Create a new document.
Click in Frame 1 of Layer 1.
Choose the paintbrush and the color red from the paint bucket. 
Draw an apple in the lower left corner of the screen.
Select it. Pull down the Modify menu and choose Convert to Symbol, 

Graphic. 

Figure 3-B. New Motion Tween.
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 Now it’s in the Library in case you need it later.
Select your apple and pull down the Modify menu and select Break 

Apart. 
 This will turn your apple into tiny pieces.
Go Frame 20 and Insert a Keyframe. Click on this Frame.
Use your paintbrush to draw a letter A on the right side of the screen.
Select your A. Pull down the Modify menu and choose Convert to 

Symbol, Graphic. 
 Now it’s in the Library in case you need it later.
Select your A and pull down the Modify menu and select Break 

Apart. 
 This will turn your A into tiny pieces.
Go back to Frame 1. 
Look below the Stage for the Properties window. 
Choose Shape from the Tween drop-down menu. 
Scrub the Timeline to see your results!

Let’s	return	to	the	airplane	example.	Rather	than	the	cloud	moving	left	
to	right,	we	want	it	to	move	from	right	to	left.	This	movement	will	give	us	
the	illusion	that	the	plane	is	passing	the	clouds.

To create a shape tween using our cloud:
Select Frame 120 of the cloud layer.
 Actually, you could select any frame you want as the end of your 

morph process.
Pull down the Insert menu, choose Timeline, select Keyframe.
 A keyframe will appear on the Timeline.
Unlock the cloud layer.

Figure 3-C. Shape Tween Animation for Alphabet Book.
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Select the cloud graphic with the pointer/arrow tool.
Move it near the left edge of the Stage.
Pull down the Modify menu, choose Break Apart.
Pull down the Modify menu, choose Ungroup.
 Your cloud is now a series of individual curves.
Select the Frame 1 of the cloud layer.
Click on the cloud on the Stage and delete it.
 Don’t worry, it’s still on Frame 120, we just don’t want it on this 

frame.
Create a new cloud using the draw tools.
 You’ll want this cloud on the right side of your screen. Do not 

group your new cloud.
Select Frame 118 of the cloud layer.
In the Properties panel, choose Shape from the Tween drop-down 

menu.
Select Angular Blend or Distributed Blend type.
Scrub the Timeline to see the results.
 Cool! The cloud on the right morphs into the cloud on the left.

Figure 3-D. Shape Tween Animation for Cloud.
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Reviewing the Basics
We’ll	add	two	other	animations	to	make	our	movie	even	more	realistic.	

First,	remove	part	of	the	runway	once	the	plane	is	off	the	ground.	Second,	
bring	the	house	into	view.	These	two	activities	don’t	require	any	new	skills.	
Instead,	they	ask	you	to	practice	and	apply	what	you	learned	in	this	chap-
ter.	I’ll	provide	a	graphic	showing	a	suggest	approach.

To animate the runway the Classic Motion Tween:
Unlock the runway layer.
Insert a Keyframe in the Timeline at Frame 120.
Drag the runway to the left so only about a half inch is showing.
Select Frame 119 and choose Classic Motion Tween.

To animate the house using the new Motion Tween:
Unlock the house layer.
Insert a Motion Tween on the house layer.
Add Property Keyframes by clicking on the Timeline and moving the 

house along the grass.
 Frame 1 and 120 should look something like the screens below.

Saving and Sharing Your Project
You’ve	completed	your	first	Flash	animation.	Way	to	go!	There	are	two	

ways	to	store	and	share	your	project.	First,	you’ll	want	to	keep	a	copy	of	
the	original	document	with	the	.fla	file	extension.	This	document	can	be	
updated	and	revised	as	you	come	up	with	other	ideas.	You	can	also	use	it	to	
review	your	skills	later.

Second,	you’ll	want	to	export	your	document	to	share	with	others.	
When	your	project	is	ready	to	upload	to	a	web	server,	attach	to	an	email,	
or	save	on	a	CD,	you’ll	want	to	export	the	project	as	a	Flash	movie	with	the	
.swf	file	extension.

Figure 3-E. Frame 1 and Frame 120.
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To save your project as a Flash movie:
Pull down the File menu, choose Export Movie.
Give your movie a short, one word descriptive name.
 Notice that the file has a .swf file extension.
Press the Save button.
 This Flash movie can now be played by anyone with the Flash 

Player installed on their computer.

If	the	file	size	of	your	project	seems	very	large,	you	may	want	to	reclaim	
some	space.	Try	choosing	SAVE	AS	from	the	File	meny	rather	than	SAVE.	
Then,	give	your	file	a	new	name.	Check	the	file	size,	it’s	likely	that	the	new	
file	is	much	smaller.	You	may	also	want	to	use	the	SAVE	AS	option	periodi-
cally	to	save	a	backup	copy	of	your	project.

Beyond the Basics
Our	first	animation	works,	but	it’s	not	fancy.	There	are	many	small	

things	that	you	can	do	spice	up	your	project.	You	can	also	refine	your	skills	
and	apply	them	to	different	situation.	Explore	a	few	techniques	to	expand	
your	skills:

Document Properties.	We	used	the	default	size	for	our	project	(550x400)	
and	a	frame	rate	of	(12fps).	However	we	used	550x100	for	our	banner.	If	
you	click	on	the	Stage	size	in	the	Properties	Panel	you’ll	also	be	able	to	add	
metadata	including	a	project	title	and	description.	You	can	also	change	the	
background	color	of	your	Stage	to	set	a	particular	mood.

Templates.	Some	people	don’t	want	to	take	the	time	to	set	up	their	proj-
ects.	Flash	comes	with	a	few	templates	for	common	types	of	movies.	If	you	
pull	down	the	File	menu	and	choose	New,	you	can	click	on	the	Templates	
to	see	the	options.
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Printing.	Many	options	are	available	for	printing.	Consider	creating	
simple	children’s	books	using	the	storyboard	printing	options.	Pull	down	
the	File	menu	and	select	Print	margins	for	many	choices.

Pencil and Pen Tools.	Most	pencil	tools	produce	jaggy	results.	However	
the	Flash	pencil	allows	the	user	to	straighten,	smooth,	and	change	the	ink.	

Choose	the	Pencil		 	tool	and	give	it	a	try!	Create	some	waves.

Making	curves	can	be	tough	unless	you	have	the	pen	tool.	It	allows	you	
to	create	cool	lines	and	Bezier	curves.	

Choose	the	Pen	 	,	click	on	the	start	point,	middle	points,	and	end	
point,	then	double	click	to	end	the	process.	Use	the	selection	tool	make	ad-
justments.	You	can	now	play	with	the	various	points.	For	a	curve,	click	the	
start	and	drag	the	mouse	in	the	desired	direction	to	start	the	curve.	Move	to	
the	desired	end	point	and	double-click.	The	curve	made	by	the	pen	tool	is	
called	a	Bezier	curve	after	a	French	engineer,	Pierre	Bezier.	It’s	a	curve	cre-
ated	from	a	set	of	control	points.	Each	point	is	calculated	by	control	points	
as	parameters.

Layers.	Once	you	start	creating	large	projects,	you’ll	find	that	dealing	
with	layers	can	get	demanding.	Consider	organizing	your	layers	into	fold-
ers.	For	example,	you	can	create	a	folder	for	all	your	actions,	media	(i.e.,	
sounds,	movies),	background	items,	text	elements,	etc.	They	can	be	orga-
nized	in	whatever	way	works	best	for	you.

Movie Clips.	We	haven’t	spent	much	time	talking	about	the	Movie	Clip	
symbol.	If	you	want	to	use	the	same	animation	a	number	of	times	within	
a	project,	you	may	want	to	create	a	movie	clip.	Also,	if	you	want	to	have	
animation	within	animation	(called	nested),	then	you	may	want	to	use	the	
Movie	Clip	symbol.	For	example,	we	could	have	many	airplanes	taking	off	
rather	than	one.	Or,	many	clouds	moving	across	the	sky.	Rather	than	creat-
ing	many	separate	airplane	or	cloud	animations,	we	could	just	use	different	
instances	of	a	cloud	movie	clip.

Let’s	say	you	want	to	have	many	balloons	rising	on	the	screen.	If	you	
create	a	movie	clip	symbol	for	one	animation,	you	can	reuse	different	in-
stances	of	that	same	movie	clip.
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Create Your Own Project
Now	that	you’ve	explored	the	basics	of	graphics	and	animation,	it’s	

time	to	develop	your	own	project.	Keep	it	simple,	but	try	to	incorporate	the	
many	possibilities	discussed	in	the	last	two	chapters.

If	you	need	an	idea,	try	a	hot	air	balloon	project.	Create	some	simple	
birds	and	clouds	in	the	sky.	Add	grass	to	the	ground.

Create	a	hot	air	balloon	using	the	graphic	tools.	Turn	it	into	a	Graphic	
Symbol.	Then,	make	the	balloon	rise	from	the	ground.	Next,	create	a	second	
hot	air	balloon	with	a	different	color	basket	and	balloon.	Animate	this	bal-
loon.	This	will	give	you	some	practice	with	motion	tweens.

For	fun,	add	some	fireworks.	Use	the	shape	tween	option	to	create	the	
effect	of	fireworks	exploding.
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Create a simple Flash project. Incorporate animation elements into a Flash project. 

Be sure to include the following elements: at least 1 text box, at least 1 shape you create in 
Flash, at least 1 graphic from somewhere else, at least 2 motion tween, at least 1 shape 
tween, and tweak the animation with motion guide and/or easing.

Save and upload both the .fla and .swf versions. 

In addition, write a short project plan to describes the purpose and audience for your anima-
tion. In other words, your project should “do” something such as tell a story (i.e., mini-car-
toon), provide a greeting (i.e., a greeting card), stimulate inquiry (i.e., ask a question), or 
advocate a position (i.e., public service announcement).

The following criteria will be used in evaluating your activity:

 • Required elements 
 • Effective, efficient, and appealing project 

AIM Your Project with Flash:
Animation


